Problem with Privateer Speech Pack

Hello all,

I have scoured the forums and google for this problem, and I can't find a solution. I recently got Privateer and RF to work great on the new dosbox (v.70), however, I cannot get the speech pack to work.

I have tried every combination of sound card settings and can't get it to work. I set my Music and Speech at SB16, DMA 1, IRQ 7, and port 220, and still can't get speech. I even tried setting both music and speech to NONE from the speech installer menu, run the game, exited the game, and then ran the regular Privateer installation to reset the sound, and still no speech.

If anyone could help me out, I'd be very grateful!

Here are my dosbox settings:

sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
mixer=true
oplmode=auto
oplrate=22050

xms=true
ems=false
umb=true
keyboardlayout=none
 

ChrisReid

Super Soaker Collector / Administrator
We need to clear up what you have, what you're getting and what you're looking for. Do you hear spoken taunts and replies in space? Do subtitles display when you talk to the bartenders and special characters on planets?

Did you just install the floppy disk Privateer Speech Pack? That only adds a couple megabytes of in-flight voices for the comm system. That is not the same thing as Privateer CD with full speech, which adds a couple hundred megabytes of digitized voice throughout all cutscenes and conversations.
 

AD

Finder of things, Doer of stuff
xms=true
ems=false
umb=true
keyboardlayout=none
MAybe I'm getting my games mixed up, but usually you have to have EMS enabled for speech. This is true with other WC titles but I don't remember for sure about Privateer. However, enabling EMS shouldn't negatively affect the game in dosbox either as you aren't running this on an old 386 with limited ram anyway.
 

ChrisReid

Super Soaker Collector / Administrator
Under the old versions of DOSBox (0.61 or so), you had to set ems=false in order to get Privateer and Armada to run. EMS is required for WC2 speech and for Academy to run at all I think, but I believe that's it.
 
Okay, I previously owned the full CD version of Privateer, so I was expecting to hear full speech. I do hear some of the in game taunts though, so I guess the floppy disk version of the speech pack did, in fact, work.

Thanks for clearing that up!
 

phalkon13

Spaceman
Thanks very much for this thread guys.

I am currently running Dosbox 0.74, and I tried every one of the sound cards, and couldn't get it to work.
Turning off EMS (ems=false) did the trick, and now the game works perfectly!

I am currently running Windows 7 Ultimate 64bit, with Dosbox 0.74
 

AD

Finder of things, Doer of stuff
Thanks very much for this thread guys.

I am currently running Dosbox 0.74, and I tried every one of the sound cards, and couldn't get it to work.
Turning off EMS (ems=false) did the trick, and now the game works perfectly!

I am currently running Windows 7 Ultimate 64bit, with Dosbox 0.74
It's an older thread, but it's awesome that you and others are still finding the pointers useful. Congrats on getting it working and enjoy!
 
Top