Privateer Sound

Viper61

Spaceman
When I run privateer, everything is fine until every now and then, teh speech comes out as just static (usually when I'm in a mission critical conversation :) ). I've spent the better part of the afternoon searching through old and stuck thread s to try and remedy my DOS sound problem but to no avail. I've pretty much given up. My final thought, is there anyway to have the sound and the text on at the same time? That would work out good for me. Thanks.

C-ya
 

Worf

Vice Admiral
I would check your DMA and 16-bit audio settings - those are the typical culprits back in the days...
 

cff

Kilk'dymga'qith laq Ik'vikvi
Originally posted by Viper61
When I run privateer, everything is fine until every now and then, teh speech comes out as just static (usually when I'm in a mission critical conversation :) ). C-ya
Try to limit your EMM memory to 16 MB.
 

Viper61

Spaceman
Tried the 16MB solution already. I have hte DMA right, but I'm unsure what you mean by the 16-bit settings.

C-ya
 

Worf

Vice Admiral
IIRC, the soundblaster BLASTER variable had, in 8-bit mode, 3 settings - I/O, interrupt, and DMA. The SB16 extended it to include, IIRC, a 16-bit DMA channel, type of card, etc.

(The 16-bit DMA is also called "high" DMA channel). Problem is, if any of those are messed up...)

You have to make sure it's completely correct, otherwise bad things happen. Of course, I don't know if there's an alternate way of setting that variable (or as usual, most games used to have their own settings).

Point is, mess it up, and it'll sorta work, but fail the rest of the time.

Of course, you never said what kind of sound card you have, either - that could often have an effect.
 

Viper61

Spaceman
I've got an internal one, I think its a crystal audio. Anyway, I made a bonehead error. I changed the config.sys RAM setting to 16MB in DOS text edit but never restarted DOS for the settings to take hold. :) Works fine now.

Thanks

C-ya
 
Top