Privateer problems- what a surprise.

Hobbie

Spaceman
Alright, I have just purchased the Gold edition of Privateer. I popped the cd in my computer and the auto-run came on. I clicked on install and I got an error message. "This program has performed an illegal operation, etc. Then I made a boot disk and treid to run in Dos. Not enough DOS memory no matter what I free up. I don't know what to do. Any suggestions?
 

Hobbie

Spaceman
autoexec.bat:

SET BLASTER=A220 I5 D1 T4
SET MSINPUT=C:\MSINPUT
C:\WINDOWS\OPTIONS\CABS\UPDATE 2
@ECHO OFF
SET PATH=C:\WINDOWS;C:\WINDOWS\COMMAND
SET PROMPT=$P$G
SET WINPMT=[Windows 95] $P$G
GOTO %CONFIG%

:WIN95
CLS
ECHO Windows is now starting
C:\WINDOWS\WIN.COM
GOTO COMMON

:MSDOS
REM BELOW LINE COMMENTED OUT BY MICROSOFT* INTELLIPOINT MOUSE SETUP*
REM LH C:\MSINPUT\MOUSE\MOUSE.EXE
IF %CDROM%.==TRUE. LH* C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD0001* /E /L:Q /M:20*
GOTO COMMON

:COMMON

config.sys:

[WIN95]
DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE 16384 RAM

[MSDOS]
DEVICE=C:\WINDOWS\HIMEM.SYS
DEVICE=C:\WINDOWS\EMM386.EXE 16384 RAM
SET CDROM=TRUE

[COMMON]
Break On
BuffersHigh=20,0
DOS=High,UMB
FCBSHigh=1,0
FilesHigh=40
StacksHigh=9,256
Switches=/F
DEVICEHIGH=C:\NECTOOLS\cdrom.sys /D:MSCD0001
device=c:\windows\cwdinit.exe /A

dosstart.bat:

REM DOS MOUSE DRIVER ADDED BY MICROSOFT* INTELLIPOINT MOUSE SETUP*
LH C:\MSINPUT\MOUSE\mouse.exe
@ECHO OFF
GOTO MSDOS

[MSDOS]
:MSDOS
C:\WINDOWS\CWDINIT.EXE /A
LH C:\WINDOWS\COMMAND\MSCDEX.EXE /D:MSCD0001* /L:Q /M:20*

device=c:\windows\cwdinit.exe /A

mem (DOS command line)

Memory
Total Used Free
Conventional 640k 72k 568k
Upper 0k 0k 0k
Reserved 384k 384k 0k
XMS 48128k 188k 47940k

Total 49152k 644k 48508k
Total under 1 MB 640k 72k 568k

Total EMS 48M
Free EMS 16M

Largest executable program size 568k
Largest free upper memblock 0k
MS-DOS is resident in the high memory area.

there ya have it.
some of these lines are ment to be on one line but the screen put them on two. I will asterix lines that are together. The two screens look different so any asterixes in 2 or 3 consecutive lines, means that they are together as one line.

[This message has been edited by Hobbie (edited September 03, 2000).]

[This message has been edited by Hobbie (edited September 03, 2000).]
 

Hobbie

Spaceman
I got the game running, but the sound doesn't work. How do I fix the drivers so that the sound will work? Thanks.
 

Pedro

Admiral
Well if you have a modern sound card it will have a dos exe or com on your sound card CD and you simply have to install the dos drivers and run that program, on older cards its more difficult.
 

Stinger

Vice Admiral
Hmm... actually, your sound card should be working, assuming you're getting to DOS through Start->Shut Down->DOS mode. The settings should be:

Sound Blaster 16
I/O: 220
IRQ: 5
DMA: 1

The CWDINIT line in DOSSTART is what actually loads the sound card driver into memory, so if for some reason it's not loading, then that's your problem.
 

Hobbie

Spaceman
Well, I managed to get the game going by using a shortcut and modifying the config,sys and autoexec.bat. I copied the lines for the sound card on autoexec.bat though. The [problem was that I got a sound configuation error when I start the game and it won't start.
 

Stinger

Vice Admiral
Well, just add in that CWDINIT line from your DOSSTART after the other sound lines and it should be fine.
 
Top