privateer joystick problem


I have gotten privateer to run on my computer but I have no mouse or joystick. I have dusted off my old CH flightstick pro and plugged it into my SB16 joystick port but I get no response at all in the game. In windows 98 everything checks out just fine for the joystick. I have loaded the dos drivers I downloaded from CH products. My SB16 is running fine as far as the sound is concerned - so I am at a freaking loss!?!?
Are there any wizards out there that could help me to get one of the best games ever made running again???

Thank in advance
Could I have a look at your config.sys and autoexec.bat? Perhaps your SB16 software isn't set up correctly. No Digital Sound wise but MIDI/Joystick Port wise...

As for getting Mouse working, look for a file called MOUSE.COM or MOUSE.EXE on your hard drive. Run it before you run Privateer to get mouse support. If you don't have MOUSE.EXE or MOUSE.COM, let me known the brand/model of your mouse so I can see what DOS drivers it would use.

[This message has been edited by Jumper (edited July 05, 2000).]
I've sent a very small general-use mouse driver to Kris to put in the files section, but I haven't gotten a response yet, and I don't see it listed there, either. I guess I'll try sending it to Crid now.

The mouse driver is called Cute Mouse; it was designed to work with almost all mice and to leave a very small footprint in conventional memory.

As for the joystick issue, it sounds to me like the gameport is disabled in software.
This is very frustrating I get to watch but can't play!
Here is my config and autoexec.




SET winbootdir=C:\WINDOWS
SET MOUSE = C:\mouse
SET BLASTER=A220 I5 D1 H1 P300 T6

I have got the mouse to work but still have not got the joystick to work. Is there suppose to be a reference in the Autoexec to your joystick??
This is getting weirder and weirder. I got a ch products utility to test the flightstick pro in DOS and it works. So I know that I have the gameport working and the flightstick pro working in DOS but I still get no response in Privateer. What gives?? Hoping for some help.

Hmm... now it's beginning to sound like a driver issue.

Explain how you tested the joystick (what program you used, how you got to DOS before testing, etc.).
Yes, it definatly sounds like a driver issue, for instance, why are there no Flightstick drivers being loaded in your config files? Strange.
The programs that I used to test the joystick were the ones that were supplied with the drivers I downloaded. The programs were Jcenter and Testall, I ran them in DOS. The movement and buttons all checked out. As fas as not having any drivers in the config or Autoexec, I don't know. I installed the drivers with FSP.exe but I did not have a line put into the autoexec.
I put in a line in the autoexec something like LH C:\fsp.exe - but all that happen was it tried to reenstall the drivers. I then changed the line to FSP.drv and nothing happened.
If there should be a line in the config refering to the drivers do you have any idea what it should look like.

How did you get to DOS when you tested these things? Was it simply a DOS box, or did you restart in DOS mode? If you restarted, did you use the same bootdisk/shortcut/whatever you use to play Privateer?
This problem sounds very familiar to me- I just spent months flying with the directional cursor buttons! In fact, I was just visiting to post a solution to it, because I found one, thanks to the guys here. First off, it’s much simpler than you are all making it. You know how everyone has trouble with the sound? The most frequently recommended fix is the SETUPSA.EXE file. Well, boys and girls there is also a joystick switch in there as well. It’s over to the right, second section down. Game port is clearly marked, and normally it’s OFF - just click to the available setting and voila- My Wingman Extreme Digital helps me fry pirates like never before! If you don’t use this file Zipper, you should- it is sort of pain to have to turn this stuff on before you play, but the payback is well worth it. And while I’m on the subject, how the hell do I play RF on the CD ROM version??? Do I actually have to complete every single mission in Privateer to move forward? Someone please help! I have the artifact, but no other leads. I went to Oxford and no one would tell me anything. Again, HELP!!!!