Privateer (again?) and music.

I've gotten tired of the old AdLib music, and I'm trying (again) to get General MIDI to work.

I have a SB AWE 64 Gold (almost like the SB Live), and its DOS AWEUTIL program is giving me fits. I also have an old LAPC-I (an MT-32 compatible sound card), which gives me some conflicts with it. If I could get either sound card to work with it, that would be great.

For my AWE card, no matter what I/O address I choose in the Privateer setup, it plays from my LAPC-I. So, I disconnected the LAPC-I, and now Privateer just crashes and I have to restart the computer. AWEUTIL, which I think is needed for this General MIDI, is also giving me problems. No matter how I load it, I can't seem to get General MIDI working for any other games, let alone Privateer. Of course, in Windows, everything (and I do mean EVERYTHING) works perfectly. But Privateer is not Windows compatible.

The other option is my LAPC-I. This is the only problem that it's ever given me, which is converting the default MT-32 patch banks to a General MIDI format. I'm using a couple MIDI files that are supposed to do the job. MTGM.MID does the regular instruments and CMR-SFX.MID does the drum set (or rhythm setup), specifically meant for LAPC-I and other MT-32 compatibles, but not the MT-32 itself. When I play the game, it sounds like the instruments work, but I don't hear any drums or other MIDI sound effects. Plus, the instruments still sound a little strange. Maybe General MIDI wasn't meant for the MT-32. In Windows, I've tried to test these MIDI files with Media Player, with the Multimedia MIDI settings on the LAPC-I, and it still won't have the drum sets working. In DOS, I use a program called GSPLAY, meant for Roland cards. Is there another program I should try using perhaps?

Whew! That's long. Well, is there anybody who can help me with a small part of this? I'd really appreciate it.
 

Stinger

Vice Admiral
I think I can help. AWEUTIL is supposed to be the answer; here's the one you're supposed to use:

AWEUTIL /EM:GM

Make sure CTCM is loaded first, of course.

Correct me if I'm wrong, but doesn't Privateer natively support both General MIDI and the MT32?
 
Hey Stinger,

AWEUTIL /EM:GM is what I have been using with CTCM loaded first, but it's with this that Privateer crashes for some reason. I also can't get other DOS games to work with this.

And I wish Privateer natively supported the MT-32. This is the System Requirements for Privateer, directly from the Origin web site.

System Requirements

Computers: MS-DOS 386/33+ or 100% compatible system
Sound Devices for Music (optional): Thunderland, Pro Audio Spectrum, Sound Blaster, Ad Lib, MPU-401 interface General MIDI or 100% compatible
Sound Devices for Speech/Sound Effects (optional): Sound Blaster, Pro Audio Spectrum or 100% compatible
Graphics Supported: 256-color VGA
RAM and HD Storage Requirements: 4 megs RAM; 5 megs hard drive space

This still means I can use the MT-32 as long as I can set it up for General MIDI correctly, which I can't seem to do.
 
DEVICEHIGH=e:\windows\emm386.exe ram

I'm don't think that's a problem, though. I've run MEM and it says I've got almost 64 megs of Expanded Memory.

I've also fiddled around with my configuration and found that Privateer will also crash if there's no General MIDI device whatsoever. It seems that it's the MIDI emulation in DOS, which points to AWEUTIL again. Am I the only one who has had a problem with getting an AWE card to work with Privateer?

For my LAPC-I, though, I found out that my changes to the card in DOS actually do work. The problem is that it seems that Privateer automatically sends a reset sysex message to the LAPC-I, thus changing it back to MT-32 style which sounds really funny in Privateer. I guess this sound card is out, unless you know of some way to block sysex messages from coming in.
 

Stinger

Vice Admiral
Actually, that probably IS the problem... Priv gets "confused" when there's more than 16 MB expanded memory available. Change the line to

DEVICEHIGH=e:\windows\emm386.exe RAM 16384

and see if AWEUTIL starts working.

As for SysEx message blockers, I know of none.
 

Stinger

Vice Admiral
I don't know the details, but trust me, it doesn't like having more than 16 MB of expanded memory available to it.
 
Nope, 16 MB of Expanded Memory didn't make a difference. However, I've heard a couple of interesting things.

First, I tried Lucasarts Tie Fighter in DOS. With AWE32 MIDI (620) it worked great, but with General MIDI (300) it crashed again. I'm wondering if there's a pattern here ...

Second, I heard that AWEUTIL doesn't work well with Protected Mode games like DOS/4GW. That would explain Tie Fighter. Is Privateer's JEMM another protected mode program?

But then if that's true, how is it that others get their AWE card to work?

Hmmm...
 

Stinger

Vice Admiral
I believe JEMM is a protected-mode thing, yes. And GM should be 330. Not sure what the difference is for other AWE cards. Are your drivers up-to-date?
 
Yes, my drivers are up to date. The reason why General MIDI on my AWE is set to 300, instead of 330, is because I also have a LAPC-I (MT-32 compatible) card, and almost all the games I use it for, default to 330 for the LAPC-I.
 
Top