Joystick doesn't work

bear_asault

Spaceman
Hey, great to be playing WC again!

My Logitech Attack 3 worked for a few missions, and now mysteriously doesn't. It works fine in FSOpen, and your launcher sees it properly, but it doesn't respond in game. Ship doesn't move, buttons don't fire, nothing. I'm running Win7 64-bit, and just updated my drivers. Any advice would be great, thanks.
 

Tolwyn

Vice Admiral
Check your settings in the launcher. Try plugging the joystick into a different usb port. If that does not help, please check the jostick value in HKEY_CURRENT_USER\Software\Volition\WingCommanderSaga and report back.
 

bear_asault

Spaceman
By 'settings in the launcher' you mean Controls/Joystick? Yeah it's selected- My two options are 'No joystick' and 'Logitech Attack 3'- in FSOpen I'm using 'Generic Joystick Driver' or something and that works fine, but I don't have that option with Saga. Tried a different port, didn't work. My HKEY value is 0x00000000 (o)

Thanks for you help
 

Tolwyn

Vice Admiral
Try setting the key value to 1 or 2 and then start the game via wcsaga_sse2.exe. Do not use the launcher. See if that helps.
 

Mace

Vice Admiral
The launcher had thesame problem here, it detects the joystick, but the game ignores it completely, there is no Joystick value in the register. The joystick calibrates correctly in joy.cpl I am running windows XP 32-bit, service pack 3 with all current updates. The rest of the game works like a charm though. The joystick itself is a Speedlink black widow with with pedal and throttle support.
 

Tolwyn

Vice Admiral
The launcher had thesame problem here, it detects the joystick, but the game ignores it completely, there is no Joystick value in the register. The joystick calibrates correctly in joy.cpl I am running windows XP 32-bit, service pack 3 with all current updates. The rest of the game works like a charm though. The joystick itself is a Speedlink black widow with with pedal and throttle support.
Please try the registry trick posted above.
 

Mace

Vice Admiral
Please try the registry trick posted above.
But these are the option I have, Standaard and Gamepath are all that are listed, what should be the name of the joystick value, not the value itself.
(It is the the dutch version of XP professional.)
 

Tolwyn

Vice Admiral
They key is called CurrentJoystick and usually the default value is 0 for the first joystick and 9999 for no joystick. Try using 1 or 2 instead. Sometimes the launcher may enumerate input devices incorrectly.
 

Mace

Vice Admiral
Set correctly, the game is completely ignoring the stick. I'm running the exe correctly, it works normally in Standoff/Secret ops, but saga appears to be ignoring it completely, currently tried the DWORD value at 1 and 2. Any other ideas or could I assist you with some information?
 

Mace

Vice Admiral
Tolwyn, I just got it, What I needed to do get it working were the following actions:
Install the beta driver for the device and replace the default MS one, also enabling force feedback functionality.
In the advanced properties of joy.cpl enable it to work for legacy applications.

At least 30 euro's well spend until I can afford the Worthog.
Saga is fully responding to all it's features now.
 
Top