itts always centered

Discussion in 'Privateer Gemini Gold' started by alfito, Jan 6, 2011.

  1. alfito

    alfito Spaceman

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Hi.

    Im running 1.0.3 on Linux. I have found that ITTS is not working at all in my game, always keeps centered on target square. I read some posts regarding ITTS not showing due damage, but this is not my case, and anyway I've got repair droid as suggested. I trying either selling and purchasing new scanner, or new ships, it happends always.
    But, I changed manually vegastrike settings file, and set always show itts as true. If I begin a new game, then looks like ITTS works, but, keeps centered if I play any of my saved games...

    Any clues?

    Thanks.
     
  2. Kenner

    Kenner Guest

    Are you saying that you manually edited the config file? And now the ITTS doesn't work? I think that might be your problem. Do you actually have a radar that is capable of ITTS?
     
  3. Darkmage

    Darkmage Vice Admiral

    Messages:
    901
    Likes Received:
    15
    Trophy Points:
    31,435
    Location:
    Australia
    tried repairing the itts in the repair section?
     
  4. Unregistered

    Unregistered Guest

    itts

    I have the same problem with my new hunter infinity scanner which I installed on my tarsus. Have'nt tried on other ships yet . The other functions of the scanner run properly, such as the fried/foe color. Space battle is not that easy without the ITTS. Have an idea for a bugfix?
     
  5. Colin Thwaites

    Colin Thwaites Spaceman

    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    0
    Gender:
    Male
    There are 2 ways to fix this (both will require expenditure but one will let you recoup some of it) .

    It seems the problem is with the Tractor Beam. It has been given ITTS connectivity but as it fires so fast, the ITTS diamond stays in the center. The issue is that the program defaults to the ITTS of the last Gun you mount on your ship which for most of us is a tractor beam.

    To fix this:

    1. Simply buy a gun after fitting the Tractor. This may of course mean selling a gun and buying it back but it will fix the problem.

    2. You can also fix it by selling the Radar unit but you have to sell it using the old Vegastrike menu found in the Ship upgrade screen (put the cursor to the far right side of the screen and click). Find your Radar in the list on the right side and sell it. Now buy another one from the list on the left. If you want to recoup your lost money from selling the Radar (but this is a cheat really), simply go back to the normal game upgrade screen, go to the software booth and sell the Radar again before buying a new one (don't ask me how it's still there, I'm just colating info on this problem from other posts I found about it).

    I've tried both methods and they work. Just save your game afterwards and remember to not buy a tractor beam as the last gun you buy.

    Cheers
     
    zarnivop likes this.
  6. zarnivop

    zarnivop Spaceman

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Gender:
    Male
    Cheers, mate. It helped me, too.
     
  7. PaulB

    PaulB Spaceman

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    50
    Gender:
    Male
    True if you buy a Tractor beam it will break ITTS. One way you can fix that is to edit the units.csv with notepad++ (do NOT use a spread sheet or Notepad or other text editor) - and look at the ships at the beginning of the file and compare them. You will some that have Turrets already installed. Copy the turret entry into the same field in the xxxx.begin (example galaxy.begin) with whatever guns you want it to have and when you Buy the Galaxy (or whcih ever shio(s) you do this to - then they will have turrets with a Tractor already built in and it WON"T cause the ITTS breakage.

    This is what I have in the Sub_Units field of galaxy.begin (it's all one line):
    {turret_medium_tachyon;1.05529e-6;-0.144535;-0.191367;0;0;1;0;-1;0;180.0}{turret_medium_tachyon;0;0.140064;-0.176212;0;0;1;0;1;0;180.0}

    Also, I find sometimes when I'm in combat that I have to press the "k" key to enable tracking and get the ITTS cursor working. "k" is not listed in the Quick Keys Guide but it is a valid key to toggle AutoTracking.
    Paul
     

Share This Page