Introducing wcdx - Kilrathi Saga for modern Windows

Salk

Rear Admiral
Great thing solving the graphical issues. Myself, I do prefer filtering though and I am looking forward to optional scaler(s).
 

Jalthi

Spaceman
Thanks very much. It seemed to work very well. I played through all of WC1, sm1, sm2 and most of WC2. It ran very smooth and I dont think it crashed at all. I'm just wandering at what fps setting is people running at? I found that the default fps setting was a little too fast and had to turn it down using ctrl+n
 

FredDude32

Commodore
For some reason SM2 doesnt work at all. I've played through WC and SM1 with no probs but SM2 just goes black when I start it.
I've tried doing a fresh install and wcdx patch but still the same thing.
 

Stinger

Vice Admiral
Since I'm manually patching each game, and there are a lot of different issues to keep track of, there will inevitably be small differences in behavior for each one. The question is how to debug it so I can figure out what's going on in your case; I don't have a good solution to that yet.
 

Stinger

Vice Admiral
Thanks very much. It seemed to work very well. I played through all of WC1, sm1, sm2 and most of WC2. It ran very smooth and I dont think it crashed at all. I'm just wandering at what fps setting is people running at? I found that the default fps setting was a little too fast and had to turn it down using ctrl+n
That's great; thanks for putting WC2 through some testing! What frame rate did you settle on?
 

Jalthi

Spaceman
No problem, thanks again I had a great time replaying the games again

For wing commander 1 I think I played mostly at 15fps and for wing commander 2 I played at 16.5 fps.

I think wing commander 1 is slightly harder especially sm2, so I need it to run a bit slower :)

Btw something i noticed on wing commander 2 if your using the thrustmaster target gui for mapping keys with a thrustmaster joystick, make sure to use the "hold function" for keys like fire missiles, because I found sometime the missiles would not fire if you use the "pulse" action, but the hold action would work everytime. Likewise I had to do the same for hat switch on my joystick to bind the front cockpit(f1) and rear(f4) views.

SO basically if your using the thrustmaster target gui mapping software and certain keys arent working properly switch it from "pulse" to "hold" it tends to work better
 

FredDude32

Commodore
Since I'm manually patching each game, and there are a lot of different issues to keep track of, there will inevitably be small differences in behavior for each one. The question is how to debug it so I can figure out what's going on in your case; I don't have a good solution to that yet.

Sorry about my comment(s). I know you are a private person doing his best for us fans. I did not mean to come across as ungrateful (which I am not). I really REALLY apreciate the work you've put into this!
 

Stinger

Vice Admiral
Whoa, hey, no need to apologize; the feedback you're giving is exactly what I want to see. I need to know what's not working in order to fix it! My message was just saying that I don't know what could be going wrong in your case. I need some more details. In particular, does the game keep running even though the screen is black? Is there music? Does the game just stop entirely? With enough additional info, I may be able to come up with some logging that would help narrow down the problem.
 

Stinger

Vice Admiral
Btw something i noticed on wing commander 2 if your using the thrustmaster target gui for mapping keys with a thrustmaster joystick, make sure to use the "hold function" for keys like fire missiles, because I found sometime the missiles would not fire if you use the "pulse" action, but the hold action would work everytime. Likewise I had to do the same for hat switch on my joystick to bind the front cockpit(f1) and rear(f4) views.

SO basically if your using the thrustmaster target gui mapping software and certain keys arent working properly switch it from "pulse" to "hold" it tends to work better

At a guess, the game is checking the active key state each frame instead of paying attention to key down/up events. At some point, I'd love to rework the input for the games, but that's not likely to happen until much further down the line.
 

FredDude32

Commodore
Whoa, hey, no need to apologize; the feedback you're giving is exactly what I want to see. I need to know what's not working in order to fix it! My message was just saying that I don't know what could be going wrong in your case. I need some more details. In particular, does the game keep running even though the screen is black? Is there music? Does the game just stop entirely? With enough additional info, I may be able to come up with some logging that would help narrow down the problem.

Just making sure.

No the game goes completely black when I start the game. No music, no indication the game is running. The game also takes up 100% CPU (or one full core in my case, 25%).
I've played around with the compatibility settings too with same results.
 

FredDude32

Commodore
This is strange.

I just tried starting the unmodified sm2.exe and it doesn't load the game either, though it doesn't chew up the CPU.
This is in contrast to the original unmodified sm1.exe which has some color issues but it still runs!
I replaced the sm2.exe from the KS CD but still the same. How come the original sm1.exe runs but not sm2.exe? :p
 

Stinger

Vice Admiral
Maybe it's a data issue? Can you try setting up the game again?

1) Copy the WC1 folder somewhere.
2) Download the Secret Missions packs, extract the .exe files to WC1, extract everything else to WC1\GAMEDAT
3) Extract wcdx to WC1 and run the patcher

It's a long shot, but it'll help narrow things down.
 

FredDude32

Commodore
Im playing it now and so far (three missions) so good. The only issue is the classic Kilrathi Saga repeating victory music bug.
 

wcnut

Rear Admiral
Are you sure you followed the instructions for fixing the music? Because that worked pretty well for me on multiple machines. (including wine)
 

Stinger

Vice Admiral
Right, the music bug can be fixed by using patchmusic. (I forgot to mention that in my previous post.)

Glad to hear it's now working for you.
 

LarkInFlight

Rear Admiral
I'm going trough WC1 secret missions 2. There is one little thing that I had hoped 'wcdx' would have fixed:

When I play SM2 (patched) the 'Dralthi missions' in KS - Dralthi's fuel and weapon indicators tend to stop in the middle - they stop halfway to 'depleted' but they ultimately run out. Of course the blaster regenerates to full but when I shoot it again, only goes to half. It's quite frustrating as I don't know how much fuel I really have once it's below middle part of the indicator.

Do you have anything like that guys? Any way to fix it?

Also when I fly Dralthi in KS the enemy always knows I'm not one of them and attack me (it's different in DOS version). Again: any way to fix it?
 

Stinger

Vice Admiral
Interesting; I've never actually played the DOS version of SM2, so I assumed that Dralthi behavior was the same in the original!
 
Top