WC Prophecy error mesh/midplas.iff

Discussion in 'Tech Support' started by Phox, Dec 12, 2011.

  1. Phox

    Phox Rear Admiral

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    21,935
    Gender:
    Male
    Location:
    Erlangen, Germany
    Hello there,

    I'm having a weird crash with Wing Commander Prophecy. It crashes back to Desktop when I enter Hrissith 1a/1b (the first mission with either Vampire or Devastator). The message I get is "Fatal: Iff:Iff open file 'mesh/midplas.iff' not found and not optional". So it would seem it cannot load some object mesh or model for the new ships.

    I'm playing on Win 7 64 bit and with OpenGL. The error occurs when I go back to using Software also, though. I did not have the enhancement pack but tried to install it to see if it helps, which it didn't. I can play the Vampire missions in the simulator and also tried some fix I found on the CIC Game Guide for Prophecy. Also googled and searched this forum but no mentioning of this error anywhere...
  2. Triple-B

    Triple-B Commodore

    Messages:
    542
    Likes Received:
    7
    Trophy Points:
    12,535
    Gender:
    Male
    Location:
    Berlin, Germany
    it seems that the midplas.iff file is missing in your folder. have you tried to reinstall wcp?
  3. Phox

    Phox Rear Admiral

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    21,935
    Gender:
    Male
    Location:
    Erlangen, Germany
    Alright it works now. After finding out that the mesh files are in DATA.TRE, I copied that file from CD1 to my installation directory (where it already was with exactly the same file size!) and that somehow did it. Not quite sure what caused the problem, maybe the OpenGL installation for WCP modified the file, although OpenGL still works now with the original data.tre. If that had not worked I would have tried to extract said .iff file from the .tre file and place it in the WCP folder/mesh subfolder directly.
  4. Lt.Overload

    Lt.Overload Commodore

    Messages:
    618
    Likes Received:
    3
    Trophy Points:
    14,685
    Gender:
    Male
    Location:
    United States of America
    Some how your Plasma Weapon Midway went missing. Now sure how that happened, but reinstalling seemed to help.
  5. PopsiclePete

    PopsiclePete Mission programmer

    Messages:
    1,244
    Likes Received:
    31
    Trophy Points:
    32,485
    Gender:
    Male
    Location:
    Amos, Québec
    Hummm... could be a file corruption. I have not stated it clearly but the launcher patches DATA.TRE with every occurence of a file found in MAT\. Obviously this shouldn't be the case here because the mesh is in MESH\, but that's the only tempering I do to DATA.TRE.

    You could try re-patching it again running "OGLsetup.exe /patchmat" and test if teh game still runs fine ? I'd like to know.
  6. Phox

    Phox Rear Admiral

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    21,935
    Gender:
    Male
    Location:
    Erlangen, Germany
    PopsiclePete, ran that command and reloaded one of the later missions and the exact same error is back. Not sure if it makes a difference but it is the german version.
  7. Triple-B

    Triple-B Commodore

    Messages:
    542
    Likes Received:
    7
    Trophy Points:
    12,535
    Gender:
    Male
    Location:
    Berlin, Germany
    I remember there was a problem with the midway carrying the plasma weapon. however, running the first simulator mission and afterwards play the actual (real)mission solved the problem.
  8. Phox

    Phox Rear Admiral

    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    21,935
    Gender:
    Male
    Location:
    Erlangen, Germany
    I tried running some of the Vampire simulator missions since I first thought it was a problem with that model as it occurred on the first Vampire/Devastator mission but that did not help. Extracting midplas.iff to a new folder mesh also fixes it though.
  9. PopsiclePete

    PopsiclePete Mission programmer

    Messages:
    1,244
    Likes Received:
    31
    Trophy Points:
    32,485
    Gender:
    Male
    Location:
    Amos, Québec
    Might be a bug of my patcher then. I'll check my code later tonight, thanks for the lead !

Share This Page