PiArmada Help

TurboTim07

Rear Admiral
after playing it a few times i kept gettin errors i copied what it gave me

Traceback (most recent call last):
File "Armada_Init.py", line 179, in ?
File "Armada_GUI.pyc", line 190, in Handle_Mouse_Up
File "Sector_Screen.pyc", line 388, in Turn_Button_Function
File "Armada_GUI.pyc", line 538, in Advance_Turn
File "Armada_AI.pyc", line 152, in Moves
ValueError: list.remove(x): x not in list
Traceback (most recent call last):
File "Armada_Init.py", line 179, in ?
File "Armada_GUI.pyc", line 190, in Handle_Mouse_Up
File "Options_Screen.pyc", line 198, in Done_Button_Function
pygame.error: No video mode large enough for 1280x1024
Traceback (most recent call last):
File "Armada_Init.py", line 179, in ?
File "Armada_GUI.pyc", line 190, in Handle_Mouse_Up
File "Options_Screen.pyc", line 198, in Done_Button_Function
pygame.error: No video mode large enough for 1280x1024
Traceback (most recent call last):
File "Armada_Init.py", line 179, in ?
File "Armada_GUI.pyc", line 190, in Handle_Mouse_Up
File "Sector_Screen.pyc", line 388, in Turn_Button_Function
File "Armada_GUI.pyc", line 538, in Advance_Turn
File "Armada_AI.pyc", line 152, in Moves
ValueError: list.remove(x): x not in list
Traceback (most recent call last):
File "Armada_Init.py", line 179, in ?
File "Armada_GUI.pyc", line 190, in Handle_Mouse_Up
File "Sector_Screen.pyc", line 388, in Turn_Button_Function
File "Armada_GUI.pyc", line 538, in Advance_Turn
File "Armada_AI.pyc", line 152, in Moves
ValueError: list.remove(x): x not in list

i understand the resolution one so i changed it back into 800x600 but i don't know why it's doin the rest :confused:
 

dracflamloc

Spaceman
Looks like x is not in the list ;)

It probably needs some error handling in there. I've posted in the other thread and offered my help to the developer. I don't know enough to help you right now though.
 

ZOmegaZ

Rear Admiral
Hmm. Yeah, the resolution error just means I need to implement some error handling, or just have it check what resolutions are available before giving you the option of switching. The other, I'm really not sure. Can you give me some detail about the state of the game when this happened?
 

TurboTim07

Rear Admiral
i understand the resolution problem. i fixed that by lowering it. but the other problem is that im playing the game and after so many turns it justs kicks me out and gives me an error message saying the error's been logged.
 

ZOmegaZ

Rear Admiral
Odds are there's more of a pattern than that. Had you perhaps explored every system when this happened? Because looking at the code, that might do it. There was also another algorithm bug there, but I don't think it would have caused a crash, just made enemy fighters auto-explore in an odd manner. Both of those have been fixed in code. Look for the next version in a few weeks.
 

TurboTim07

Rear Admiral
i hadn't explored everything that i know off because there were still unexplored systems. the first time it happened was when i attacked the enemy carrier with everything i had. the second time it happened was after exactly seven of my turns. i played the version before this and there were no problems. to me it seems very random. but i'll try playin it again tonight to see if there's a pattern
 
Top