installing XWA in XP

TurboTim07

Rear Admiral
hey all. i've been trying to install X-Wing Alliance onto my computer which runs XP but when i try it says:

16 bit Windows Subsystem
C:\WINDOWS\SYSTEM32\AUTOEXEC.NT. The system file is not suitable for running MS-DOS and Microsoft Windows applications. Choose 'Close' to terminate the application.

Now that's the same thing it says when i try to install an DOS based game such as Command and Conquer. but XWA is a Win 95 game. so if anyone could help me by telling how to install XWA onto my computer i'd be really thankful (if you could tell me how to install DOS games onto my computer that'd be a bonus as well :D )

p.s.
i've tried using DOSBox and the D-Fend frontend but it doesn't seem to work or im not doing something right.
 

Death

gh0d (Administrator)
Have you tried creating a shortcut to the installer, and setting the shortcut properties to Win95 emulation?

(And on a related note, that autoexec.nt notice simply means you need to dig into the directories on your XP disk and copy it to the HD directory it mentions. I forget where on the CD it's located at the moment, though.)
 

culler

Spaceman
Your autoexec.nt is probably either corrupted or missing. You can usually find the original autoexec.nt in C:\Windows\repair

In a command prompt:
copy c:\windows\repair\autoexec.nt c:\windows\system32

On a somewhat related note, XWA doesn't run well on my computer, the sound is choppy (I had to turn off DirectX sound acceleration to even get sound to work, otherwise it would error with "sound not available") and the framerates in-flight is really bad, it pauses momentarily everytime a ship or planet gets into your view. This happens on low or high resolutions, and even with the lowest detail settings. Does anyone know how to fix it? (PC: Athlon 1800+, 256mb, Radeon 9700 Pro, Asus A7N8X-E Deluxe on-board sound)
 

Edfilho

Cry some more!
I have no trouble running it in a Athlon XP 2800+ with 512 DDR RAM and XPproSP2... are your drivers uptodate?
 

culler

Spaceman
Actually the inflight seems to have worked itself out. What is still broken however, are the video cut-scenes, eg. the intro video. The animation is not smooth and the sound is choppy. I have up to date ATI Catalyst drivers, XP Pro with SP2, and drivers for the on-board sound.. oh well, at least the game itself is playable.
 

Dahan

Rear Admiral
That is odd..I run Alliance on my computer and it has XP and it has no trouble at all...very strange
 
Top