Help! USB Joystick in Privateer 1 (using DosBox)

Discussion in 'Tech Support' started by Malander, Oct 11, 2008.

  1. Malander

    Malander Spaceman

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    :confused: I finally got a copy of WC Privateer this past friday again (been a while since I played and got it working... mostly. I am unable to get it to properly respond to my Logitech Extreem 3D pro stick. The curser in game keeps running away on me up and to the left.

    Thus far nothing I have done within the doxbox config file has helped. Only setting joystick to none and restarting doxbox and then the game helps but that limits me to keyboard and mouse controls only.

    Does anyone have an idea of what I can do?
  2. AD

    AD Finder of things, Doer of stuff Staff Member

    Messages:
    4,588
    Likes Received:
    35
    Trophy Points:
    36,885
    Location:
    BC, Canada
    Is the stick calibrated correctly in windows (in the control panel and then in game controllers)?
  3. Malander

    Malander Spaceman

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Near as I can tell, yes. Unless somehow I have to also configure the logitec profiler for WC Privateer but for just basic commands should it not just accept it seeing as windows seems ok with all buttons and such? Bad stick perhaps or just Privateer doesn't like it?
  4. AD

    AD Finder of things, Doer of stuff Staff Member

    Messages:
    4,588
    Likes Received:
    35
    Trophy Points:
    36,885
    Location:
    BC, Canada
    Is it still running away though? Are you saying that the primary fire button isn't working (Priv doesn't support more than a two button mouse without external mapping software). Did you try running the calibration in the game itself?

    Also, make sure you don't have any other game controlers (usb or gameport) plugged in at the same time.
  5. AD

    AD Finder of things, Doer of stuff Staff Member

    Messages:
    4,588
    Likes Received:
    35
    Trophy Points:
    36,885
    Location:
    BC, Canada
    Also, make sure you don't have any other game controlers (usb or gameport) plugged in at the same time.
  6. Malander

    Malander Spaceman

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Yes I had run the ingame calibration but it does not help. Only things plugged in via USB are my mouse and ofcourse the joysitck, well ok the printer too but that's kinda beside the point. :) But yes, it does keep running away on me no matter what I have tried thus far. It does not wait for me to be in flight either. Even the load / new etc screen I can tell then that it is running away on me.
  7. ChrisReid

    ChrisReid Super Soaker Collector / Administrator Staff Member

    Messages:
    12,452
    Likes Received:
    86
    Trophy Points:
    69,485
    Location:
    Seattle, Washington, USA
    This happens to me in Privateer in DOSBox, but only when I start the game before having the joystick turned on. I have a Logitech Wireless Freedom. Have you made sure that the joystick is all good to go and then restarted DOSBox and Priv? If you haven't already, you should also experiment with the joystick options - joysticktype, timed and swap34 settings definitely.
  8. Unregistered

    Unregistered Guest

    Hey Malander!
    have you found any solution to your problem yet?
    I have the same trouble with the Joystick running to the upper left...
    It sucks because despite that Privateer is working perfectly well on my system!
  9. Kirby2000

    Kirby2000 Guest

    I've just installed Privateer in DOSBOX .72. I tried all the joystick options and the ones that worked for me are:

    [joystick]
    joysticktype=2axis
    timed=false
    autofire=false
    swap34=false
    buttonwrap=true

    "timed=false" seemed to be the line that worked. After that you may still need to go to options in the game menu and recalibrate your joystick and that should stop it going up and to the left.
  10. Unregistered

    Unregistered Guest

    Joystick problem

    If the cursor still jumps into the upper corner of the screen after checking for calibration...
    go into the key mapper utility and delete all the joystick functions on the lower diagram and
    then delete the "2" on the upper diagram leaving the "1" and the + and - intact for the X and Y axis.
    In the configuration file...set the joystick to joysticktype=auto and Timed=false

    Good hunting !!
  11. Unregistered

    Unregistered Guest

    controller errors

    I changed the dosbox.config timed to false now instead of spinning is does not work at all.
  12. Dundradal

    Dundradal Frog Blast the Vent Core! Staff Member

    Messages:
    6,213
    Likes Received:
    51
    Trophy Points:
    51,985
    Location:
    Seattle, Washington, USA
    I had this problem and by changing timed=false and then running Privateer's internal calibration was able to remove the drifting problem. This was with DOSBox .74

Share This Page